Wrong duration values in Smil files

Forums: 

Dear all,

Some French users have reported a new problem with Smil files produced with an exportation in Daisy 2.02 format.
The value of attribute "dur" is wrong. The numeric separator is a comma and the decimals values are missing.

See this exemple : seq id="sq34" dur="19,s"

Is there a solution to resolve this problem?

With regards,
Jean-Pierre

Dear Jean,

Thanks for reporting your issue.
May i know which Obi version are you using, as we have already fixed this
issue in our previous release Obi 3.9 Alpha.
Also in Daisy 2.02 , in which format are you exporting ( eg. wave,mp3..).

Thanks.

Regards
Rachana

Dear Rachana,

We are using Obi 3.9 beta and the exportation files are in MP3 format.
The numeric separator for “clip-begin” and “clip-end” are now correct but the attribute of "dur" value is wrong. On all Smil files the decimal value of duration is missing and for some files, the separator is a comma instead a point.

Example :
seq id="sq25" dur="59,s"
...
audio src="aud003_03_4ème_de_couverture.mp3" clip-begin="npt=54.25s" clip-end="npt=59.768s" id="aud44" /

Best regards,
Jean-Pierre

Dear Rachana,

We are using Obi 3.9 beta and the exportation files are in MP3 format.
The numeric separator for “clip-begin” and “clip-end” are now correct but the attribute of "dur" value is wrong.
On all Smil files the decimal value of duration is missing and on some files, the separator is a comma instead a point.

Example :
seq id="sq25" dur="59,s"
...
audio src="aud003_03_4ème_de_couverture.mp3" clip-begin="npt=54.25s" clip-end="npt=59.768s" id="aud44"

Best regards,
Jean-Pierre

Dear Jean

Please follow the instructions in the following link
http://www.copsmodels.com/gpcommapnt.htm

With regards
Avneesh

Dear Avneesh,

With the modification in the Regional and Language Options, the value of the attribute "dur" is now correct.
Thanks a lot,

Jean-Pierre