Solved: Strange DAISY book playback issue in AMIS, PTR 2 and some other DAISY readers

Forums: 

The issue: A library from Europe reported that the books they have created recently with Obi are not playing properly. In AMIS, the playback stutters that is parts of words are cut off. In PTR 2 when page navigation is attempted, the device restarts. The library had not changed the hardware or software in the DAISY production unit. The same setup had been creating DAISY books for many years without any problem. They tried different versions of Obi but that also did not help.

Solution: The library contacted DAISY technical support team. They were asked to provide a sample book. Upon deep investigation it was revealed that on the Library production PC, "comma" was set as the Decimal symbol. The result was that in the DAISY books created by Obi, in the SMIL files all the time references were mentioned using comma (,) as the separator. For example the SMIL files had entries like - clip-end="npt=1,974s". The time 1,974 could not be interpreted by some DAISY readers and therefore the playback did not proceed properly.

The library was advised to go to Control Panel > Regional Settings > Number Format and change the Decimal Symbol to "." (period). The library has reported that there problem is solved now and all their books are working find in DAISY readers.