DAISY 3 to DAISY 2.02[BETA] bug

Forums: 

I might have find a bug in PIPELINE DAISY 3 to DAISY 2.02[BETA] script.
SMIL totalElapsedTime´s and timeInThisSmil´s are rounded to seconds and it´s problem with validation.

example

This is original DAISY3 smil

and after DAISY 3 to DAISY 2.02[BETA]

and validation error

[INPUT] - !ERROR! - expected total elapsed time 0:00:06.807 but found 0:00:07 - file:/C:/***************/speechgen0002.smil
[INPUT] - !ERROR! - expected duration 0:00:44.027 but found 0:00:44 - file:/C:/*****************/speechgen0002.smil

Could this be fixed? We need this to downgrade our daisy3 books every now and then.

Teppo Huttunen
________________________________________
Oppikirjatuotanto / ääni- / yhdistelmäkirjat
Celia-kirjasto
Postiosoite: PL 20, 00030 IIRIS
Käyntiosoite: Marjaniementie 74, Helsinki
Puh. 0400-296452
teppo.huttunen@celia.fi
www.celia.fi

Have you tried to increase the "Time Tolerance" value (in the optional script parameters) ? That should solve the problem by ignoring rounding errors.

Hope this helps, Romain.

Yes, that did it! Now it works. Didn´t know that one. Thanks!